# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"@(.*)(@[\s\S]*)@default\.\1.*"
test_str = ("@d.e.f@=y\n"
"@a.b.c@=x\n"
"@h.i.j@=aaaa\n"
"@default.a.b.c@=QQQ\n"
"@asdfasd.fasdfs.asdfa@=23423\n"
"@default.h.i.j@=234\n"
"@default.RR.TT@=393993\n"
"@x.y.z@=0\n"
"@default.q.r.s@=1\n"
"@l.m.n@=8.3\n"
"@q.r.s@=78\n"
"@blah.blah.blah@=blah")
subst = "@$1$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.