re = /@(.*)(@[\s\S]*)@default\.\1.*/
str = '@d.e.f@=y
@a.b.c@=x
@h.i.j@=aaaa
@default.a.b.c@=QQQ
@asdfasd.fasdfs.asdfa@=23423
@default.h.i.j@=234
@default.RR.TT@=393993
@x.y.z@=0
@default.q.r.s@=1
@l.m.n@=8.3
@q.r.s@=78
@blah.blah.blah@=blah'
subst = '@$1$2'
result = str.sub(re, subst)
# Print the result of the substitution
puts result