import Foundation
let pattern = #"@(.*)(@[\s\S]*)@default\.\1.*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
@d.e.f@=y
@a.b.c@=x
@h.i.j@=aaaa
@default.a.b.c@=QQQ
@asdfasd.fasdfs.asdfa@=23423
@default.h.i.j@=234
@default.RR.TT@=393993
@x.y.z@=0
@default.q.r.s@=1
@l.m.n@=8.3
@q.r.s@=78
@blah.blah.blah@=blah
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"@$1$2"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}