#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "@(.*)(@[\s\S]*)@default\.\1.*"
Local $sString = "@d.e.f@=y" & @CRLF & _
"@a.b.c@=x" & @CRLF & _
"@h.i.j@=aaaa" & @CRLF & _
"@default.a.b.c@=QQQ" & @CRLF & _
"@asdfasd.fasdfs.asdfa@=23423" & @CRLF & _
"@default.h.i.j@=234" & @CRLF & _
"@default.RR.TT@=393993" & @CRLF & _
"@x.y.z@=0" & @CRLF & _
"@default.q.r.s@=1" & @CRLF & _
"@l.m.n@=8.3" & @CRLF & _
"@q.r.s@=78" & @CRLF & _
"@blah.blah.blah@=blah"
Local $sSubst = "@$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)