# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[&?]language.*?(?=&|\?|$)//gm;t' <<< "/fr/welcome?param1=222¶m2=aloa&language=en
/fr/welcome?language=en
/fr/welcome?param1=222&language=en¶m2=aa"