re = /[&?]language.*?(?=&|\?|$)/m
str = '/fr/welcome?param1=222¶m2=aloa&language=en
/fr/welcome?language=en
/fr/welcome?param1=222&language=en¶m2=aa'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result