#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[&?]language.*?(?=&|\?|$)"
Local $sString = "/fr/welcome?param1=222¶m2=aloa&language=en" & @CRLF & _
"/fr/welcome?language=en" & @CRLF & _
"/fr/welcome?param1=222&language=en¶m2=aa"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)