use strict;
my $str = '/fr/welcome?param1=222¶m2=aloa&language=en
/fr/welcome?language=en
/fr/welcome?param1=222&language=en¶m2=aa';
my $regex = qr/[&?]language.*?(?=&|\?|$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";