$re = '/[&?]language.*?(?=&|\?|$)/m';
$str = '/fr/welcome?param1=222¶m2=aloa&language=en
/fr/welcome?language=en
/fr/welcome?param1=222&language=en¶m2=aa';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;