using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[&?]language.*?(?=&|\?|$)";
string substitution = @"";
string input = @"/fr/welcome?param1=222¶m2=aloa&language=en
/fr/welcome?language=en
/fr/welcome?param1=222&language=en¶m2=aa";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}