import Foundation
let pattern = #"[&?]language.*?(?=&|\?|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/fr/welcome?param1=222¶m2=aloa&language=en
/fr/welcome?language=en
/fr/welcome?param1=222&language=en¶m2=aa
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)