#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+)\s(\d+)\s(.*?)\s\d{1,2},\s\d{4}\.pdf$"
Local $sString = "1234 12345678 TEST DOCUMENT December 20, 2018.pdf" & @CRLF & _
"1234 12345678 TESTDOCUMENT December 20, 2018.pdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")