$re = '/(\d+)\s(\d+)\s(.*?)\s\d{1,2},\s\d{4}\.pdf$/m';
$str = '1234 12345678 TEST DOCUMENT December 20, 2018.pdf
1234 12345678 TESTDOCUMENT December 20, 2018.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);