import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)\\s(\\d+)\\s(.*?)\\s\\d{1,2},\\s\\d{4}\\.pdf$";
final String string = "1234 12345678 TEST DOCUMENT December 20, 2018.pdf\n"
+ "1234 12345678 TESTDOCUMENT December 20, 2018.pdf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}