const regex = /(\d+)\s(\d+)\s(.*?)\s\d{1,2},\s\d{4}\.pdf$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)\\s(\\d+)\\s(.*?)\\s\\d{1,2},\\s\\d{4}\\.pdf$', 'gm')
const str = `1234 12345678 TEST DOCUMENT December 20, 2018.pdf
1234 12345678 TESTDOCUMENT December 20, 2018.pdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}