package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)\s(\d+)\s(.*?)\s\d{1,2},\s\d{4}\.pdf$`)
var str = `1234 12345678 TEST DOCUMENT December 20, 2018.pdf
1234 12345678 TESTDOCUMENT December 20, 2018.pdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}