re = /(\d+)\s(\d+)\s(.*?)\s\d{1,2},\s\d{4}\.pdf$/m
str = '1234 12345678 TEST DOCUMENT December 20, 2018.pdf
1234 12345678 TESTDOCUMENT December 20, 2018.pdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end