using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)\s(\d+)\s(.*?)\s\d{1,2},\s\d{4}\.pdf$";
string input = @"1234 12345678 TEST DOCUMENT December 20, 2018.pdf
1234 12345678 TESTDOCUMENT December 20, 2018.pdf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}