#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<a[^>]*href=["']([^"']*)["']"
Local $sString = "<p class="bc_shirt_delete">" & @CRLF & _
" <a href="/CustomContentProcess.aspx?CCID=13524&OID=3936923&A=Delete" onclick="javascript:return confirm('Are You sure you want to delete this item?')">delete</a>" & @CRLF & _
"</p>" & @CRLF & _
"" & @CRLF & _
"<a class="test" href="https://goog.le/">test</a>" & @CRLF & _
"<a class="test" href='https://goog.le/'>test</a>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")