const regex = /<a[^>]*href=["']([^"']*)["']/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a[^>]*href=["\']([^"\']*)["\']', 'gm')
const str = `<p class="bc_shirt_delete">
<a href="/CustomContentProcess.aspx?CCID=13524&OID=3936923&A=Delete" onclick="javascript:return confirm('Are You sure you want to delete this item?')">delete</a>
</p>
<a class="test" href="https://goog.le/">test</a>
<a class="test" href='https://goog.le/'>test</a>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}