re = /<a[^>]*href=["']([^"']*)["']/m
str = '<p class="bc_shirt_delete">
<a href="/CustomContentProcess.aspx?CCID=13524&OID=3936923&A=Delete" onclick="javascript:return confirm(\'Are You sure you want to delete this item?\')">delete</a>
</p>
<a class="test" href="https://goog.le/">test</a>
<a class="test" href=\'https://goog.le/\'>test</a>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end