using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a[^>]*href=[""']([^""']*)[""']";
string input = @"<p class=""bc_shirt_delete"">
<a href=""/CustomContentProcess.aspx?CCID=13524&OID=3936923&A=Delete"" onclick=""javascript:return confirm('Are You sure you want to delete this item?')"">delete</a>
</p>
<a class=""test"" href=""https://goog.le/"">test</a>
<a class=""test"" href='https://goog.le/'>test</a>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}