use strict;
my $str = '<p class="bc_shirt_delete">
<a href="/CustomContentProcess.aspx?CCID=13524&OID=3936923&A=Delete" onclick="javascript:return confirm(\'Are You sure you want to delete this item?\')">delete</a>
</p>
<a class="test" href="https://goog.le/">test</a>
<a class="test" href=\'https://goog.le/\'>test</a>
';
my $regex = qr/<a[^>]*href=["']([^"']*)["']/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}