// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<a[^>]*href=["']([^"']*)["']"#).unwrap();
let string = "<p class=\"bc_shirt_delete\">
<a href=\"/CustomContentProcess.aspx?CCID=13524&OID=3936923&A=Delete\" onclick=\"javascript:return confirm('Are You sure you want to delete this item?')\">delete</a>
</p>
<a class=\"test\" href=\"https://goog.le/\">test</a>
<a class=\"test\" href='https://goog.le/'>test</a>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}