import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a[^>]*href=[\"']([^\"']*)[\"']";
final String string = "<p class=\"bc_shirt_delete\">\n"
+ " <a href=\"/CustomContentProcess.aspx?CCID=13524&OID=3936923&A=Delete\" onclick=\"javascript:return confirm('Are You sure you want to delete this item?')\">delete</a>\n"
+ "</p>\n\n"
+ "<a class=\"test\" href=\"https://goog.le/\">test</a>\n"
+ "<a class=\"test\" href='https://goog.le/'>test</a>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}