# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^#\|\h+label:\h+|\G(?!^))[^\r\n_]*\K_/-/gm;t' <<< "#| label: my_chunk_label
my_function_name <- function(x)"