const regex = /(?:^#\|\h+label:\h+|\G(?!^))[^\r\n_]*\K_/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^#\\|\\h+label:\\h+|\\G(?!^))[^\\r\\n_]*\\K_', 'gm')
const str = `#| label: my_chunk_label
my_function_name <- function(x)`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);