re = /(?:^#\|\h+label:\h+|\G(?!^))[^\r\n_]*\K_/m
str = '#| label: my_chunk_label
my_function_name <- function(x)'
subst = '-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result