$re = '/(?:^#\|\h+label:\h+|\G(?!^))[^\r\n_]*\K_/m';
$str = '#| label: my_chunk_label
my_function_name <- function(x)';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;