#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:^#\|\h+label:\h+|\G(?!^))[^\r\n_]*\K_"
Local $sString = "#| label: my_chunk_label" & @CRLF & _
"my_function_name <- function(x)"
Local $sSubst = "-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)