import Foundation
let pattern = ##"(?:^#\|\h+label:\h+|\G(?!^))[^\r\n_]*\K_"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
#| label: my_chunk_label
my_function_name <- function(x)
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)