#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:[\-a-z]+\.)+(dev|laravel)"
Local $sString = "http://www.google.com" & @CRLF & _
"http://www.google.com/maps" & @CRLF & _
"http://schollmeyer-test.westwerk.dev/de/legal-recruitment/aktuelle-jobs/aktuelle-jobs-in-deutschland/" & @CRLF & _
"facebook.dev" & @CRLF & _
"facebook.com" & @CRLF & _
"test-ing.facebook.sub.dom-main.local" & @CRLF & _
"test-ing.facebook.sub.dom-main.local.dev" & @CRLF & _
"http://flora.local.dev" & @CRLF & _
"promoplan.westwerk.sf.dev"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")