import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[\\-a-z]+\\.)+(dev|laravel)";
final String string = "http://www.google.com\n"
+ "http://www.google.com/maps\n"
+ "http://schollmeyer-test.westwerk.dev/de/legal-recruitment/aktuelle-jobs/aktuelle-jobs-in-deutschland/\n"
+ "facebook.dev\n"
+ "facebook.com\n"
+ "test-ing.facebook.sub.dom-main.local\n"
+ "test-ing.facebook.sub.dom-main.local.dev\n"
+ "http://flora.local.dev\n"
+ "promoplan.westwerk.sf.dev";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}