package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:[\-a-z]+\.)+(dev|laravel)`)
var str = `http://www.google.com
http://www.google.com/maps
http://schollmeyer-test.westwerk.dev/de/legal-recruitment/aktuelle-jobs/aktuelle-jobs-in-deutschland/
facebook.dev
facebook.com
test-ing.facebook.sub.dom-main.local
test-ing.facebook.sub.dom-main.local.dev
http://flora.local.dev
promoplan.westwerk.sf.dev`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}