$re = '/(?:[\-a-z]+\.)+(dev|laravel)/i';
$str = 'http://www.google.com
http://www.google.com/maps
http://schollmeyer-test.westwerk.dev/de/legal-recruitment/aktuelle-jobs/aktuelle-jobs-in-deutschland/
facebook.dev
facebook.com
test-ing.facebook.sub.dom-main.local
test-ing.facebook.sub.dom-main.local.dev
http://flora.local.dev
promoplan.westwerk.sf.dev';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);