use strict;
my $str = 'http://www.google.com
http://www.google.com/maps
http://schollmeyer-test.westwerk.dev/de/legal-recruitment/aktuelle-jobs/aktuelle-jobs-in-deutschland/
facebook.dev
facebook.com
test-ing.facebook.sub.dom-main.local
test-ing.facebook.sub.dom-main.local.dev
http://flora.local.dev
promoplan.westwerk.sf.dev';
my $regex = qr/(?:[\-a-z]+\.)+(dev|laravel)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}