using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[\-a-z]+\.)+(dev|laravel)";
string input = @"http://www.google.com
http://www.google.com/maps
http://schollmeyer-test.westwerk.dev/de/legal-recruitment/aktuelle-jobs/aktuelle-jobs-in-deutschland/
facebook.dev
facebook.com
test-ing.facebook.sub.dom-main.local
test-ing.facebook.sub.dom-main.local.dev
http://flora.local.dev
promoplan.westwerk.sf.dev";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}