import Foundation
let pattern = #"(?:[\-a-z]+\.)+(dev|laravel)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
http://www.google.com
http://www.google.com/maps
http://schollmeyer-test.westwerk.dev/de/legal-recruitment/aktuelle-jobs/aktuelle-jobs-in-deutschland/
facebook.dev
facebook.com
test-ing.facebook.sub.dom-main.local
test-ing.facebook.sub.dom-main.local.dev
http://flora.local.dev
promoplan.westwerk.sf.dev
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)