#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s*\(+[^()]*\b(address|house).*"
Local $sString = "This is a string ((X.address)) test" & @CRLF & _
"This is a string ((X address)) test" & @CRLF & _
"This is a string (X address) test" & @CRLF & _
"This is a string (X.address) test" & @CRLF & _
"This is a string ((X and Y and Z address)) test" & @CRLF & _
"" & @CRLF & _
"This is a string ((X.house)) test" & @CRLF & _
"This is a string ((X house)) test" & @CRLF & _
"This is a string (X house) test" & @CRLF & _
"This is a string (X.house) test" & @CRLF & _
"This is a string ((X and Y and Z house)) test"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)