re = /\s*\(+[^()]*\b(address|house).*/m
str = 'This is a string ((X.address)) test
This is a string ((X address)) test
This is a string (X address) test
This is a string (X.address) test
This is a string ((X and Y and Z address)) test
This is a string ((X.house)) test
This is a string ((X house)) test
This is a string (X house) test
This is a string (X.house) test
This is a string ((X and Y and Z house)) test'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result