package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*\(+[^()]*\b(address|house).*`)
var str = `This is a string ((X.address)) test
This is a string ((X address)) test
This is a string (X address) test
This is a string (X.address) test
This is a string ((X and Y and Z address)) test
This is a string ((X.house)) test
This is a string ((X house)) test
This is a string (X house) test
This is a string (X.house) test
This is a string ((X and Y and Z house)) test`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}