$re = '/\s*\(+[^()]*\b(address|house).*/m';
$str = 'This is a string ((X.address)) test
This is a string ((X address)) test
This is a string (X address) test
This is a string (X.address) test
This is a string ((X and Y and Z address)) test
This is a string ((X.house)) test
This is a string ((X house)) test
This is a string (X house) test
This is a string (X.house) test
This is a string ((X and Y and Z house)) test';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;