// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s*\(+[^()]*\b(address|house).*").unwrap();
let string = "This is a string ((X.address)) test
This is a string ((X address)) test
This is a string (X address) test
This is a string (X.address) test
This is a string ((X and Y and Z address)) test
This is a string ((X.house)) test
This is a string ((X house)) test
This is a string (X house) test
This is a string (X.house) test
This is a string ((X and Y and Z house)) test";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}