using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*\(+[^()]*\b(address|house).*";
string substitution = @"";
string input = @"This is a string ((X.address)) test
This is a string ((X address)) test
This is a string (X address) test
This is a string (X.address) test
This is a string ((X and Y and Z address)) test
This is a string ((X.house)) test
This is a string ((X house)) test
This is a string (X house) test
This is a string (X.house) test
This is a string ((X and Y and Z house)) test";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}