#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?J)^.*something1,(?:,|(?<src_username>[^,\\]+),|(?<src_domain>[^,\\]+)\\(?<src_username>[^,\\]+),)(?:,|(?<dst_user>[^\\,]+),|(?<dst_domain>[^,\\]+)\\(?<dst_username>[^,\\]*),)something2.*"
Local $sString = "something1,,,something2" & @CRLF & _
"" & @CRLF & _
"something1,,dstuser,something2" & @CRLF & _
"" & @CRLF & _
"something1,,dstdomain\dstuser,something2" & @CRLF & _
"" & @CRLF & _
"something1,srcdomain\srcuser,,something2" & @CRLF & _
"" & @CRLF & _
"something1,srcdomain\srcuser,dstdomain\dstuser,something2" & @CRLF & _
"" & @CRLF & _
"something1,srcuser,dstdomain\dstuser,something2" & @CRLF & _
"" & @CRLF & _
"something1,srcuser,dstuser,something2" & @CRLF & _
"" & @CRLF & _
"something1,srcuser,,something2" & @CRLF & _
"" & @CRLF & _
"something1,srcdomain\srcuser,dstuser,something2" & @CRLF & _
"" & @CRLF & _
"something1,srcdomain\srcuser,dstdomain\dstuser,something2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")