use strict;
my $str = 'something1,,,something2
something1,,dstuser,something2
something1,,dstdomain\\dstuser,something2
something1,srcdomain\\srcuser,,something2
something1,srcdomain\\srcuser,dstdomain\\dstuser,something2
something1,srcuser,dstdomain\\dstuser,something2
something1,srcuser,dstuser,something2
something1,srcuser,,something2
something1,srcdomain\\srcuser,dstuser,something2
something1,srcdomain\\srcuser,dstdomain\\dstuser,something2';
my $regex = qr/(?J)^.*something1,(?:,|(?<src_username>[^,\\]+),|(?<src_domain>[^,\\]+)\\(?<src_username>[^,\\]+),)(?:,|(?<dst_user>[^\\,]+),|(?<dst_domain>[^,\\]+)\\(?<dst_username>[^,\\]*),)something2.*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}