# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?J)^.*something1,(?:,|(?<src_username>[^,\\]+),|(?<src_domain>[^,\\]+)\\(?<src_username>[^,\\]+),)(?:,|(?<dst_user>[^\\,]+),|(?<dst_domain>[^,\\]+)\\(?<dst_username>[^,\\]*),)something2.*"
test_str = ("something1,,,something2\n\n"
"something1,,dstuser,something2\n\n"
"something1,,dstdomain\\dstuser,something2\n\n"
"something1,srcdomain\\srcuser,,something2\n\n"
"something1,srcdomain\\srcuser,dstdomain\\dstuser,something2\n\n"
"something1,srcuser,dstdomain\\dstuser,something2\n\n"
"something1,srcuser,dstuser,something2\n\n"
"something1,srcuser,,something2\n\n"
"something1,srcdomain\\srcuser,dstuser,something2\n\n"
"something1,srcdomain\\srcuser,dstdomain\\dstuser,something2")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.