import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?J)^.*something1,(?:,|(?<src_username>[^,\\\\]+),|(?<src_domain>[^,\\\\]+)\\\\(?<src_username>[^,\\\\]+),)(?:,|(?<dst_user>[^\\\\,]+),|(?<dst_domain>[^,\\\\]+)\\\\(?<dst_username>[^,\\\\]*),)something2.*";
final String string = "something1,,,something2\n\n"
+ "something1,,dstuser,something2\n\n"
+ "something1,,dstdomain\\dstuser,something2\n\n"
+ "something1,srcdomain\\srcuser,,something2\n\n"
+ "something1,srcdomain\\srcuser,dstdomain\\dstuser,something2\n\n"
+ "something1,srcuser,dstdomain\\dstuser,something2\n\n"
+ "something1,srcuser,dstuser,something2\n\n"
+ "something1,srcuser,,something2\n\n"
+ "something1,srcdomain\\srcuser,dstuser,something2\n\n"
+ "something1,srcdomain\\srcuser,dstdomain\\dstuser,something2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}