// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?J)^.*something1,(?:,|(?<src_username>[^,\\]+),|(?<src_domain>[^,\\]+)\\(?<src_username>[^,\\]+),)(?:,|(?<dst_user>[^\\,]+),|(?<dst_domain>[^,\\]+)\\(?<dst_username>[^,\\]*),)something2.*").unwrap();
let string = "something1,,,something2
something1,,dstuser,something2
something1,,dstdomain\\dstuser,something2
something1,srcdomain\\srcuser,,something2
something1,srcdomain\\srcuser,dstdomain\\dstuser,something2
something1,srcuser,dstdomain\\dstuser,something2
something1,srcuser,dstuser,something2
something1,srcuser,,something2
something1,srcdomain\\srcuser,dstuser,something2
something1,srcdomain\\srcuser,dstdomain\\dstuser,something2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}