$re = '/(?J)^.*something1,(?:,|(?<src_username>[^,\\\\]+),|(?<src_domain>[^,\\\\]+)\\\\(?<src_username>[^,\\\\]+),)(?:,|(?<dst_user>[^\\\\,]+),|(?<dst_domain>[^,\\\\]+)\\\\(?<dst_username>[^,\\\\]*),)something2.*/m';
$str = 'something1,,,something2
something1,,dstuser,something2
something1,,dstdomain\\dstuser,something2
something1,srcdomain\\srcuser,,something2
something1,srcdomain\\srcuser,dstdomain\\dstuser,something2
something1,srcuser,dstdomain\\dstuser,something2
something1,srcuser,dstuser,something2
something1,srcuser,,something2
something1,srcdomain\\srcuser,dstuser,something2
something1,srcdomain\\srcuser,dstdomain\\dstuser,something2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);